Adobe: Исправлено 13 критических уязвимостей в продуктах

AdobeКомпания Adobe выпустила пакет очередных обновлений для:

  • Shockwave Player;
  • Flash Professional;
  • Photoshop;
  • Illustrator.


В общей сложности исправлено 13 критических уязвимостей, позволяющие атакующим получить контроль над целевой системой.

Из них:

  • В Shockwave Player 11.6.4.634 (и более ранних версиях) - исправлено пять критических уязвимостей. Используя данные уязвимости, злоумышленник мог вызвать нарушение в работе памяти и удаленно выполнить вредоносный код на целевой системе. Для устранения уязвимостей, пользователям рекомендуется обновить приложение до версии 11.6.5.635.

  • В Illustrator CS5.5 (и более ранних версиях) - обнаруженные дефекты могли привести к нарушению в работе памяти и позволить взломщикам захватить контроль над системой. Для устранения уязвимостей, пользователям настоятельно рекомендуется установить обновления для этого приложения.

  • В приложениях Photoshop и Flash Professional - исправлены уязвимости типа "user-after-free" и переполнения буфера, при  эксплуатации которых можно удаленно выполнить вредоносный код на целевой системе.


Обновления для Photoshop, Illustrator и Flash компания Adobe распространяет за дополнительную плату. Согласно предложению, получить новую версию программ можно примерно за $200.


Обновлено (10.05.2012 22:05)