Android-устройства подвержены новым уязвимостям Stagefright 2.0


AndroidИсследователь безопасности из компании Zimperium Джошуа Дрэйк (Joshua Drake) обнаружил в Stagefright две уязвимости. При этом, уязвимость:

  • CVE-2015-6602 - содержится во всех редакциях Android, начиная с первой;
  • CVE-2015-3876 - в версии Android 5.0.


Эксперт утверждает, что бреши затрагивают более миллиарда Android-устройств, при этом, по сути все, которые используются на данный момент. В компании Google заверили, что обновление, исправляющее уязвимости, будет доступно с 5 октября 2015 года.

По степени опасности новые бреши, названные Stagefright 2.0, ни чем не уступают оригинальной Stagefright. Эксплуатируя их, атакующий, при помощи специально созданных файлов MP3 или MP4, может удаленно выполнить код и получить контроль над скомпрометированным устройством. Таким образом, злоумышленник получит доступ к персональным данным и снимкам, которые хранятся на девайсе. Кроме того, он сможет:

  • делать фотографии;
  • записывать разговоры;
  • похищать электронные письма;
  • SMS/MMS сообщения;
  • загружать дополнительные приложения.


Чтобы осуществить атаку, злоумышленнику необходимо обманом заставить пользователя посетить определенные web-сайты и проэксплуатировать уязвимость через ссылки в электронных письмах и мгновенных сообщениях или через вредоносные рекламные объявления, размещенные на легитимных ресурсах.

Кроме того, атакующие, которые способны перехватить интернет-соединение пользователя (используя доступные беспроводные сети или через скомпрометированные маршрутизаторы) могут внедрить эксплоит непосредственно в не зашифрованный трафик.

Напомним, в августе нынешнего года тем же исследователем были опубликованы подробности о критической уязвимости в компоненте ядра мобильной ОС Android под названием Stagefright. Еще тогда эксперт отметил, что в скором времени могут быть обнаружены и другие проблемы, о которых он и другие специалисты сообщат команде безопасности Google.

Эксперты Zimperium сообщили о брешах команде Google и теперь ожидают, когда будет выпущено корректирующее обновление. После этого они намерены опубликовать PoC-эксплоит.


Обновлено (02.10.2015 06:11)